IPInfoOffline

IPInfoOffline v1.44
Copyright (c) 2008 - 2016 Nir Sofer
Web site: http://www.nirsoft.net

Description

IPInfoOffline Allows you to view information about IP addresses, without connecting any external server. It uses a compressed IP addresses database that is stored inside the exe file.
For each IP address, the following information is displayed: IP block range, Organization (RIPE, ARIN, APNIC, LACNIC or AFRINIC), Assigned Date, Country Name, and Country Code. After retrieving the information about the desired IP addresses, You can copy the information to the clipboard, or save it into text/html/xml/csv file.

System Requirements

This utility works with any version of Windows from Windows 98 to Windows 10.

Versions History

  • Version 1.44:
    • Updated the internal IP to country database.
  • Version 1.43:
    • Fixed the 'Select IP Addresses' window to support Ctrl+A (Select All).
    • Updated the internal IP to country database.
  • Version 1.42:
    • Updated the internal IP to country database.
  • Version 1.41:
    • Fixed IPInfoOffline to detect IP address when it's enclosed with brackets.
  • Version 1.40:
    • Added support for GeoLite City database. You can now download the GeoLite City database (GeoLiteCity.dat.gz), put it in the same folder of IPInfoOffline.exe, and IPInfoOffline will automatically use it to get the country/city information for every IP address.
  • Version 1.35:
    • Updated the internal IP to country database.
  • Version 1.34:
    • Updated the internal IP to country database.
  • Version 1.33:
    • Updated the internal IP to country database.
  • Version 1.32:
    • Updated the internal IP to country database.
  • Version 1.31:
    • When IPInfoOffline loads an external IP-Country file (IpToCountry.csv), information about that is displayed in the status bar.
  • Version 1.30:
    • IPInfoOffline now remembers that last size and position of the 'Select IP Addresses' window.
    • Fixed bug: The Organization column displayed empty string.
    • Updated the internal IP to country database.
  • Version 1.26:
    • Updated the internal IP to country database.
  • Version 1.25:
    • Updated the internal IP to country database.
  • Version 1.23:
    • Updated the internal country names list.
  • Version 1.22:
    • Updated the internal country names list.
  • Version 1.21:
    • Updated the internal IP to country database.
  • Version 1.20:
    • Added command-line support for saving IP addresses information into a file without any user interface. For example:
      IPInfoOffline.exe /iplist "88.64.10.10 89.64.20.20 12.10.20.30" /shtml c:\temp\ip.html
    • Fixed the IP addresses sorting
    • Updated the internal IP to country database.
  • Version 1.18:
    • Added 'Add Header Line To CSV/Tab-Delimited File' option. When this option is turned on, the column names are added as the first line when you export to csv or tab-delimited file.
    • Updated the internal IP to country database.
  • Version 1.17:
    • Updated the internal IP to country database.
  • Version 1.16:
    • Added F9 accelerator key for opening the 'Choose IP Addresses' window.
    • Updated the internal IP blocks list.
  • Version 1.15:
    • Added /AddCountry command-line option that allows you to inject country name for each IP address inside a text file. You can use this feature for adding country data into the Output of other tools like tracert and ping.
  • Version 1.10:
    • Added 'European Union' string for .eu IP addresses and 'Reserved' string for Reserved addresses (e.g: 192.168.x.x)
    • Added 'Index' column that displays the order of the IP addresses in your list.
    • Updated the internal IP blocks list.
  • Version 1.05:
    • Added new option: Don't add duplicate IP addresses.
    • Added new option: Don't add duplicate IP blocks.
  • Version 1.00 - First release.

Using IPInfoOffline

IPInfoOffline doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - IPInfoOffline.exe
After running IPInfoOffline, you can type the IP addresses that you want to inspect, and then click 'Ok'.

Using External IP To Country File

although the exe of IPInfoOffline already contains the IP addresses database, you can still use an external IP To Country file from the following link: http://software77.net/geo-ip/
If you put the IpToCountry.csv file downloaded from this Web site in the same folder of IPInfoOffline, it will automatically be loaded by IPInfoOffline and will be used instead of the internal IP database.

Starting from version 1.40, you can also use the GeoLite City database. You should download the GeoLite City database (GeoLiteCity.dat.gz), put it in the same folder of IPInfoOffline.exe, and IPInfoOffline will automatically use it to get the country/city information for every IP address.

/AddCountry Command-Line Option

/AddCountry is a unique command-line option that allows you to inject country name for each IP address found inside the text file that you specify. This command-line option can be useful for adding country information for the output tracert and other network related tools.
The usage of /AddCountry is very simple:
/AddCountry [Source Filename] [Destination Filename]

If you don't specify the second parameter, the result will be saved into the source filename.

Example for using /AddCountry:
tracert -d www.nirsoft.net > c:\temp\trace1.txt
IPInfoOffline.exe /AddCountry "c:\temp\trace1.txt"

Translating IPInfoOffline to other languages

In order to translate IPInfoOffline to other language, follow the instructions below:
  1. Run IPInfoOffline with /savelangfile parameter:
    IPInfoOffline.exe /savelangfile
    A file named IPInfoOffline_lng.ini will be created in the folder of IPInfoOffline utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run IPInfoOffline, and all translated strings will be loaded from the language file.
    If you want to run IPInfoOffline without the translation, simply rename the language file, or move it to another folder.

Command-Line Options

/iplist <IP Addresses List> | Specifies a list of IP addresses to load. For example: IPInfoOffline.exe /iplist "88.64.10.10 89.64.20.20 12.10.20.30"
/stext <Filename> | Save the IP addresses information into a regular text file.
/stab <Filename> | Save the IP addresses information into a tab-delimited text file.
/scomma <Filename> | Save the IP addresses information into a comma-delimited text file (csv).
/stabular <Filename> | Save the IP addresses information into a tabular text file.
/shtml <Filename> | Save the IP addresses information into HTML file (Horizontal).
/sverhtml <Filename> | Save the IP addresses information into HTML file (Vertical).
/sxml <Filename> | Save the IP addresses information into XML file.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com